Thursday, September 20, 2012

Dart Language meeting notes from Sept 17

Bob Nystrom posted the latest Dart language meeting notes to the mailing list. Bob writes:

Here's my notes from this weeks meeting:

0.11 language spec

I asked when we'd be publishing the next version of the language spec. Gilad says "real soon now". We keep making changes so we don't want to publish just to immediately invalidate something a few days later.

scope of type parameters

Gilad brought up what happens if you try to access a type parameter within a static method:

class Foo<T> {
  static bar() => T; // <- What does this mean?

Currently they are just not in scope, which means it could refer to some other outer name.

Instead, maybe we should say they are in scope, but you can't use them, which is consistent with other names inside a class.

Kasper says there one's scope. It doesn't matter whether you are on the instance or static side. You'll just get an error if you try to refer to something from the wrong side.

warnings on built-in identifiers

Gilad wonders if the warnings aren't helpful for things like "get" and "set" even though they are allowed. We discussed not showing a full warning but maybe some sort of "suggestion" that you shouldn't do that. We've decided to drop the warnings.

limited stack traces

The language spec was changed recently to state that when you get a stack trace in a catch, it only includes the stack frames from between the throw and the catch, but nothing past that. This means users can't get the full context for how an exception was reached.

Lars said the intent was can look at the catch handlers on the stack to see if you need to collect stack trace at all. We never intended it to be partial stack trace. The semantics were always intended to be entire stack trace.

Gilad will update the spec.

cascaded calls in initializer expressions

Right now, you have to parenthesize them, and we're not sure why. Gilad will look into the grammar and see if it doesn't work out.

lowercase string

Kasper said early on they discussed aliases for things like Integer -> int. But then they figured people would use a mishmash of both, which would be ugly and inconsistent. Instead, they chose to go with a single name for each built in type.

Lars said they looked at the built-in types and picked a list of them that they felt should have easier lowercase names. They didn't want all of them, so they had to draw the line somewhere. They are happy with "String" as it is.