Friday, November 28, 2014

Dart 1.8: library improvements and experimental support for enums

Would you like to try out Dart’s upcoming support for enums? In Dart Editor under Tools > Preferences > Experimental you can “Enable Enums Support” and start experimenting with code like:


With Dart 1.8, a number of library improvements have also landed. 
  • In dart:collection, SplayTree added toSet() method, and in dart:convert a JsonUtf8Encoder class was added. 
  • In dart:core, the following three things were added: 
    • New properties and constructors for RangeError
    • A new IndexError class - used by the RangeError.index constructor
    • Optional start and end arguments for the String.fromCharCodes constructor.
  • In dart:io we added support for the ALPN extension of the TLS secure networking protocol for Client and Server.
For a summary of these and others changes see the release notes. You can download Dart 1.8 from the Download Dart page. If you are running the Dart Editor, you can update by checking "About Dart Editor". Check out the Dart support page for information on getting help, filing issues, and contributing to the project.