Skip to main content

Getting packages ready for Dart 2

And making your packages look great on the Pub site!


We expect the Dart 2 release to graduate to stable in the immediate future. Thus, it’s critical that you migrate your code — especially any packages you have published — to be Dart 2 compatible now!

To support this work we’ve made some enhancements to the Pub site to better show potential issues. See our Medium post for full details.